Kobo, EPUB3 et Adobe Digital Editions 4.5

Si un usager obtient le message d'erreur "Votre liseuse n’est pas autorisée à ouvrir ce livre. Ce livre est protégé par Adobe Digital Rights Management (DRM).", il est fort probable qu'il s'agisse d'un livre en EPUB3, et que le problème rencontré par l'usager vienne d'une incompatibilité Kobo / Epub3 / ADE 4.5, en présumant que l'usager a une version 4.5 de ADE sur son ordinateur.


La plupart des livres numériques récents sont en format EPUB3, et c'est pour cette raison que le problème peut être rencontré avec plusieurs livres numériques.  Pour savoir si un livre numérique est un EPUB2 ou un EPUB3, cliquer ici.

C'est un problème qui survient lorsqu'on ouvre un fichier en format EPUB3 dans ADE version 4 ou 4.5, et qu'on le transfère sur une liseuse Kobo. ADE modifie très légèrement le code du DRM, et cette modification n'est pas reconnu par Kobo. Malheureusement, c'est quelque chose qui nous échappe complètement.

Très souvent, il faut installer la version 3.0 pour régler le problème, en s'assurant de bien effacer toute trace des précédentes versions. En effet, l'ordinateur peut garder des traces de plusieurs versions d'ADE et donc peut être mêlé. 

Nous souhaitons qu'éventuellement le problème soit résolu à la base, soit que les epub3 puissent être lus correctement dans les versions récentes de ADE lors du transfert vers la Kobo. C'est quelque chose qui échappe malheureusement au contrôle de Bibliopresto, car cela concerne la compatibilité entre le produit d'Adobe (ADE) et Rakuten (Kobo).

La procédure pour désinstaller ADE et installer la version 3.0 est disponible ici.  Il suffit de cliquer sur le lien dans l'encadré suivant:


Pour vous aider, vous pouvez consulter nos capsules vidéo de formation en lien avec cette procédure :


Si jamais notre procédure et nos capsules vidéo ne règlent pas le problème, nous vous invitons à consulter l'article concernant un autre contournement de ce problème


Note : Pour les usagers qui ont Windows 10 et qui désirent installer la version 3.0 d'ADE, Windows demandera l'installation d'une composante Microsoft.Net nécessaire pour Adobe 3.0. En tant que tel, c'est un package nécessaire à l'application (potentiellement à plusieurs autres anciennes applications aussi) et il ne devrait pas causer de problème.  Le message affiché peut ressembler à celui-ci:

Adobe Digital Editions 3.0 requires Microsoft .NET Framework 3.5 Service Pack 1.  Please install and try again.  Would you like to proceed do .NET download page ?
Date de création: 13/07/2021 11:25 (LPelletier)      Mis à jour: 23/03/2022 11:33 (LPelletier)
Fichiers
DataImage3.png
31,2 KB